Site Navigation

Your Account

Choose Language

Question Closed

Printrbot does not communicate with computer WIN-PC

Pronterface software does not CONNECT to printrbot.

USB driver was installed successfully. Power supply works, LED on board lights up, USB cable is connected.

Com ports are listed on pronterface software.

I tried this on four different computers, same result

for about six hours. This is a new printrbot plus printer.

Do you believe that the PC board is defective, wires

crossed? Do you have an actual wiring schematic drawing so that I can carefully check the connections?

I have done everything that I can think of. What are

your suggestions?


Richard Atcheson

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

I had a similar problem 2 days ago, did you try switching between all available com#(s). and clicking connect after selecting each and every one? and of coarse waiting for the console to register it's verdict?

Also it might be helpful if you told us what console said after each attempt to connect.

Was this answer helpful?

Score 0
Add a comment

Is the Printrbot listed in Devices and Printers?

I removed my board from underneath the bed and installed it into a separate container. When installing into the new case, I decided to put the screws in upside down to make it easier to install the board into it's new case.

The good news is that it was easier to install the board.

The bad news is that the computer no longer picked up the Printrbot.

Check the corners where the bolts are inserted, if there are any washers, remove them they don't belong there and they will cause a short giving you this exact symptom.

Was this answer helpful?

Score 0
Add a comment

I had the same problem.

Somewhere I had seen something about running as administrator.

I'm not sure if this is what fixed the problem but when I did it Pronterface

came alive and I had a valid intrerface. Under windows 7:

1) Go to 'Start'

2) Search for 'Serial Install'

3) Right click on 'Serial Install'

4) Select 'Properties from drop down screen

5) Select 'Compatabilty' tab

6) Under 'Privilege level' check the"Run this program as administrator" box

7) Select 'Serial Install' file and run it.

Hope this does it for you.


Was this answer helpful?

Score 0
Add a comment